WordPress Ajax Contact Form with attachments 2.0


Ajax Formulário de contato Construtor com anexos enviando e sem controle de spam (arraste e solte, reCaptcha, ayah) para WordPress

O w2 Ajax Formulário de contato para WordPress é uma solução completa e fácil de usar para criar um formulário de contato ajax no WordPress. Projetado para ser um plugin flexível, este item oferece características clássicas e originais totalmente configuráveis ​​através de um painel do Plugin do administrador do AJAX Fulll. Você pode criar com facilidade (criador de formulários de arrastar e soltar fácil de usar) seus próprios formulários. Além disso, você pode personalizar rapidamente seu apearence de formulários usando a interface de administrador do plugin.

Drag & Drop form builder:

Você pode criar facilmente seus próprios modelos de formulário (adicionar ou remover campos) através do criador de formulários Drag and Drop.

Personalização fácil do tema:

Você pode editar facilmente a apearence do seu formulário usando a interface de edição rápida. Se você precisar de mais, você pode criar seu próprio tema CSS usando a interface de edição do tema (CSS Completo).

Salvar mensagens de correio no banco de dados:

Você pode salvar suas mensagens no banco de dados.

Painel de administração do plugin AJAX completo:

Administração de plugin fácil de usar.

Versão 2.0:

  • Adicionado Drag & Drop form constructor.
  • Adicionado o painel de administração do plugin AJAX completo.
  • Característica adicionada para salvar mensagens no banco de dados.
  • Adicionado o botão soundcloud.
  • Função adicional para edição rápida do CSS.
  • Adicionado suporte de várias páginas de formulário.
  • Adicionado suporte para ferramentas.

Sem controle de spam (arrastar e soltar)

O Drag'n'drop No Spam Control é uma alternativa fácil de usar para o Captcha tradicional.
Não é um recurso de drag'n'drop simples para exibir o botão de envio. É uma solução anti-spam completa.

O No Spam Control controla o tempo entre cada submissão (max / min configurável) e gera alguns campos Hiddens com uma chave de criptografia (configurável) quando o dragger é descartado. Os campos ocultos são gerados com alfanuméricos aleatórios e Tempo (criptografados por meio da chave de criptografia) para garantir que os campos de Nenhum controle de spam estejam disponíveis apenas por um período limitado (configurável).

Esta é uma proteção muito segura e fácil de usar. Então é fácil personalizá-lo com CSS.

Há 4 tipos para nenhum controle de Spam:

  • basic (simplesmente drag'n'drop)
  • cores (drag'n'drop a cor certa)
  • números (não arraste o número certo)
  • formas (não arraste a forma certa)

O plugin permite que você use outra solução capctha como o Google ReCaptcha ou AYAH (você é um ser humano).

Requisitos mínimos

  • versão PHP 5.x (PHP5 ou superior).
  • WordPress 3.7 ou superior.

Compatibilidade com temas – Versão de teste (Try Before Buy)

Você pode testar a compatibilidade do plugin com o seu tema usando o
Plugin de Compatibilidade de Tema – Versão de Teste (basta instalar o plugin no seu wordpress).

Se o plugin não for exibido corretamente nas páginas de front-end ou back-end do seu tema, parece haver um conflito de tema (conflito entre o plugin e seu tema).
O plugin inclui recursos para resolver o conflito do tema (seção Configurações globais), então, se houver um conflito de tema e você quiser comprar o plugin, entre em contato com o suporte técnico (envie o URL da página onde o formulário está sendo exibido) para conhecer o Configuração correta da seção Configurações Globais para resolver o conflito do tema.

Interface do plugin do administrador (tente antes de comprar)

Você pode testar a Interface de Plugin de Administrador: Demo Back office.
Assista aos tutoriais de Vídeos.

Versão autônoma disponível

Bibliotecas PHP e JavaScript

  • Este plugin usa alguns componentes PHP Zend (Zend Mail, Zend Mime) para mapear recursos.

    O componente Zend Mail é uma das bibliotecas de mailling mais poderosa e profissional. Ele permite que você entregue um email limpo (encodageamento e anexos) para todos os tipos de caixa postal (desktop ou móvel).
  • Ele usa plugins clássicos jQuery como jQuery Ui, jQuery Form, jQuery Validation. Todos os temas (jQuery UI) e arquivos de tradução para plugins são incluídos no pacote.

Características

  • Arquivos de anexos múltiplos ou únicos (configuráveis).
  • Destinatário múltiplo ou único (simultaneamente ou não).
  • Otimizado para iDevices (responsivo).
  • Fácil de criar sua própria forma (drag & dorp form editor).
  • Você pode criar seu próprio modelo de formulário.
  • Você pode criar seu próprio tema CSS e adicioná-los automaticamente às suas listas de Tema no editor de formulários.
  • Função de resposta automática (configurável).
  • Salvar mensagens no banco de dados
  • Você pode especificar suas próprias regras de validação de campos.
  • A mensagem de e-mail aceita conteúdo HTML (configurável).
  • Você pode criar vários formulários e salvá-los no banco de dados.
  • Inegração no conteúdo da sua página "automática" ou via "código curto".
  • O recurso de arrastar e soltar (sem controle de spam) possui 4 modelos diferentes (veja a visualização ao vivo).
  • O recurso de arrastar e soltar (sem controle de spam) está pronto para tela sensível ao toque.
  • Integração ReCaptcha.
  • E mais …

Suporte Técnico

Para uma resposta rápida, envie-me uma mensagem privada através do meu perfil.
agência web

  divirta-se!

ChangeLog

se você já comprou o plugin é realmente recomendado para instalar a atualização mais recente para corrigir alguns erros e adicionar novos recursos.

Não se esqueça de ler o arquivo "upgrade_instructions.txt" antes de atualizar a instalação do plugin.

  • versão 2.0.27:

    • Problema corrigido com a inclusão de personalização de etiquetas de entrada de anexo.
    • Corrigido PHP <5.5 erro.
  • versão 2.0.26:

    • Possibilidade adicional de especificar seleção de campo e delimitador csv para exportação CSV.
  • versão 2.0.25:

    • Adicionado o tipo de conteúdo do aviso legal para poder adicionar aviso legal no formulário enviar (aceitar ou recusar).
    • Possibilidade adicional de desativar o envio de mensagens se não especificar qualquer destinatário.
  • versão 2.0.24:

    • Corrigido erro PHP para PHP versão 7.
  • versão 2.0.23:

    • Possibilidade adicional de usar o campo de arquivo múltiplo HTML5.
    • Adicionado novo retorno de chamada do PHP antes doValidForm.
  • versão 2.0.22:

    • Parâmetros adicionados para especificar a data padrão, a data mínima, a data máxima e o intervalo de ano para cada campo datepicker no construtor de formulários.
  • versão 2.0.21:

    • Adicionado parâmetro para especificar o formato de data do campo datepicker no construtor de formulário.
  • versão 2.0.20:

    • Corrigido erro PHP para PHP 7.
  • versão 2.0.19:

    • Característica adicionada para desabilitar a verificação da versão do plugin.
    • efeito de desvanecimento removido na lista de formulários.
  • versão 2.0.18:

    • O bug do construtor de formulário corrigido para o formulário contém muito elemento.
  • versão 2.0.17:

    • Adicionado timestamp, usuário IP e URL referer no rodapé da mensagem de correio.
    • Corrigido a edição do título da página do bug no form constructor.
  • versão 2.0.16:

    • Adicionado novo recaptcha do Google.
    • Adicionado xlsx entension para arquivo de anexo.
    • notificação de arquivo anexada fixa indefinida.
  • versão 2.0.15:

    • Dimensão incorreta do elemento arrastado corrigido (largura e altura) no construtor de formulários para wordpress 4.1.
  • versão 2.0.14:

    • Corrigido o nome do remetente do auto resposta incorreto na caixa postal.
  • versão 2.0.13:

    • Função adicionada para exportar os emails salvos como arquivo CSV.
  • versão 2.0.12:

    • Adicionado atributo de notificação anexada a dados HTML5 para exibir notificação de texto para o arquivo de arquivo anexo.
  • versão 2.0.11:

    • Corrigir aviso depreciado para mysql_real_escape_string.
  • versão 2.0.10:

    • Característica adicionada para adicionar a notificação de "entrada incompleta" para a validação de javascript.
  • versão 2.0.9:

    • Corrigido erro para personalização de aparência de campo.
    • Corrigido erro para personalização de notificação de entrada de arquivo personalizado.
  • versão 2.0.8:

    • Adicionado a personalização de texto de notificação do tipo de arquivo no form.,
  • versão 2.0.7:

    • Corrigido erro para seleção de idioma.
    • Temas atualizados do CSS.
  • versão 2.0.6:

    • Característica adicionada para adicionar o destinatário cc ou bcc usando este synthax "bcc: recipient@mail.net".
    • Layout de grade CSS atualizado para centrar os elementos da grade.
  • versão 2.0.5:

    • Formulário de formulário substituído pelo nome do formulário nas tabelas de dados de mensagens.
  • versão 2.0.4:

    • Característica adicionada para carregar as bibliotecas de UI do WordPress jQuery em vez do pacote personalizado jQuery UI (disponível apenas no back-office).
  • versão 2.0.3:

    • Corrigiram bibliotecas de CSS de caminho errado em fornt end para usuário não registrado ao usar código curto nativo.
  • versão 2.0.2:

    • Característica adicionada para usar o recurso de shortcode nativo do WordPress em vez do carregamento da biblioteca inteligente.
  • versão 2.0.1:

    • Adicionado salvar cada campo valores individualmente no banco de dados.
  • versão 2.0:

    • Adicionado Drag & Drop form constructor.
    • Adicionado o painel de administração do plugin AJAX completo.
    • Característica adicionada para salvar mensagens no banco de dados.
    • Adicionado o botão soundcloud.
    • Função adicionada à edição rápida do CSS.
    • Adicionado suporte de várias páginas de formulário.
    • Adicionado suporte para ferramentas.
  • versão 1.3.1:

    • Adicionado falta de Zend Validar arquivos de biblioteca para envio de correio via smtp.
  • versão 1.3.0:

    • : o processo de tradução mudou desde a versão 1.3.0. Agora, todos os arquivos de tradução (PHP e JS) estão nos idiomas das pastas. As notificações PHP estão nas línguas da pasta / php / default /. O arquivo .tmx foi substituído por arquivos .php simples. Então, se você quiser atualizar as notificações, verifique esses arquivos.
    • O pacote de instalação do plugin foi minimizado atualizando o processo de tradução.
    • Característica adicionada para especificar mensagem e assunto de resposta automática, a mensagem enviada e não enviada através do painel de administração do plugin sem editar arquivos de tradução.
    • Adicionado um novo recurso para exportar o tema CSS criado através do edtitor do código-fonte. Você pode gerar automaticamente seu CSS personalizado como um novo Form CSS Theme. Mais informações.
    • Adicionado novas regras CSS responsivas para caixa de mensagem nospam.
    • Re-trabalhou o tema CSS para formar elementos de formulário.
    • Corrigido erro CSS para textarea redimensionável.
    • Característica adicionada para configurar automaticamente o caminho para o arquivo wp-load.php.
  • versão 1.2.33:

    • Adicionado um novo recurso para enviar e-mail para todos os destinatários automaticamente (sem usar campos ocultos).
    • Adicionado idioma holandês (nl).
  • versão 1.2.32:

    • Arquivos de tradução adicionados para o widget datepicker (datepicker usará o parâmetro lang de notificação).
    • Adicionado o parâmetro "auto" para o parâmetro lang de notificação. Esta configuração permite que você use seu idioma wordpress como idioma de notificação do plugin (somente para o idioma existente).
    • Possibilidade de mudar o nome da pasta do plugin (se você precisar).
  • versão 1.2.31:

    • Notificação adicional para a nova versão do plugin disponível.
    • Corrigido CSS (box-sizing) bug para WordPress 3.6 padrão tema.
  • versão 1.2.30:

    • Corrigido bug para língua portuguesa brasileira.
  • versão 1.2.29:

    • Adicionado nova tradução para a língua brasileira portuguesa.
  • versão 1.2.28:

    • Transição CSS adicionada para IE10.
  • versão 1.2.27:

    • Corrigir erro para o espaço reservado no IE9.
  • versão 1.2.26:

    • Novo recurso para adicionar arquivos de anexo à mensagem de resposta automática.
  • versão 1.2.25:

    • Adicionar possibilidade à biblioteca UI jquery não ativada para desabilitar todos os recursos de interface do usuário (UI wigdets, controle nospam).
  • versão 1.2.24:

    • Adicione o carregador para o controle nospam para exibir o botão "enviar" somente quando os campos ocultos do nospam estão completamente carregados (útil para conexão do servidor lento).
  • versão 1.2.23:

    • Corrigir erro para o script "regras específicas de validação" (desde a versão 1.2.19).
  • versão 1.2.22:

    • Detecção automática adicional para arquivos adicionais de laguages.
  • versão 1.2.21:

    • Corrigir o erro CSS para entrada de arquivo personalizado no IE10.
  • versão 1.2.20:

    • Possibilidade de especificar diferentes arquivos de tradução para cada formulário (útil para usar várias mensagens de resposta automática).
    • Adicionando novo laguage (Português).
  • versão 1.2.19:

    • Removendo linhas de interrupção no código de instanciação do plugin javascript para evitar problemas quando o parâmetro "tema tem rodapé" é "falso" (para carregar o script de instancia no conteúdo) com o tema WP usando o recurso "wpautop".
  • versão 1.2.18:

    • Possibilidade de adicionar valor de campos na mensagem de resposta automática (basta usar shortcode [field_name] no conteúdo da mensagem de resposta de correio).
    • Novo modelo de formulário HTML com marcador de posição de atributo HTML5.
  • versão 1.2.17:

    • Possibilidade de configurar o parâmetro "Notification lang" (configurações globais) para "auto". No modo automático, o formulário usará o idioma do WordPress. Se o idioma não existir no seu arquivo "w2_cf_notifications.tmx" (você pode adicionar seu próprio idioma), o idioma usado por padrão será o inglês.
  • versão 1.2.16:

    • atualizou a biblioteca PHP AYAH para corrigir o erro
  • versão 1.2.15:

    • Adicionado novo método de validação para Expressão regular (validação de javascript).
    • Possibilidade de atualizar o texto de tradução do plugin de formulário de contato jquery para o idioma "en" e "en_US" no arquivo "js / w2_contact_form / localization / message_en.js" e "../message_en_US.js.
  • versão 1.2.14:

    • Possibilidade de configurar a lista de seleção de página (exibindo opções) para exibir todo o status do Post Type (não só publicado).
  • versão 1.2.13:

    • Método de adição para limpar o arquivo temporário gerado para integração de código rígido PHP. Se você usa a integração difícil do PHP, é realmente recomendável usar esta atualização.
    • Corrigir o erro de envio de e-mail ao usar caracteres especiais para o parâmetro "nome do site" (Configurações globais).
  • versão 1.2.12:

    • Novas opções de configurações globais.
  • versão 1.2.11:

    • Barra de progresso para upload de arquivos anexos
    • Melhoramento da segurança.
  • versão 1.2.10:

    • Novo recurso para configurar o caminho do arquivo wp-config.php.
    • CSS transição agora disponível para navegador Chrome, Safari e Opera.
  • versão 1.2.9:

    • Novo sistema para redefinir o banco de dados do plugin. Faça isso clicando no butoon "Redefinir o banco de dados do plugin", não pelo plugin não ativado. Este sistema impede a perda indesejada de dados do formulário quando o usuário não é ativo no plugin.
  • versão 1.2.8:

    • Novo retorno de retorno enviar sucesso para criar função de javascript específica para evento de sucesso enviar. Exemplo, você pode aplicar um desvanecimento ao formulário após a apresentação do sucesso.
  • versão 1.2.7:
    • Recarga automática de AYAH após a apresentação do formulário.
    • Corrigir o erro CSS para a cor do envio do botão com o CSS theme hot-sneaks.
  • versão 1.2.6:
    • Possibilidade de usar o código PHP no editor de código-fonte HTML quando você integra o formulário através do código rígido PHP (somente disponível para a integração do código PHP).
    • Possibilidade de criar o modelo do assunto do correio, incluindo o valor do campo de formulário existente.
       Exemplo:
      Mensagem de [firstname] [lastname] [mail]
  • versão 1.2.5:
    • Corrigir conflito CSS com algum tema wp.
  • versão 1.2.4:
    • Possibilidade de carregar todas as bibliotecas do plugin js no rodapé (útil para resolver algum conflito do tema wp).
  • versão 1.2.3:
    • Possibilidade de não carregar jquery para WP-themes que não usam a biblioteca jquery incluída do WordPress.
  • versão 1.2.2:
    • Possibilidade de não especificar o remetente de e-mail para usar o e-mail do usuário como remetente de e-mail.
    • Corrigir conflito CSS com algum tema WP.
  • versão 1.2.1:
    • Corrigir erro PHP para conflito com outro plugin AYAH.
  • versão 1.2.0:
    • Atualização automática do recurso de banco de dados para as próximas atualizações do plugin (trabalho para a versão> 1.1.8).
    • Possibilidade de carregar a UI jquery no rodapé (útil para resolver algum conflito).
    • Possibilidade de exibir todos os Tipos de Mensagens na lista de seleção de página.
    • Possibilidade de efeito de cor não ativo para a notificação de validação js (útil para resolver algum conflito).
    • Se você atualizar o plugin de uma versão <1.1.9, você precisa desativar e reativar o plugin para redefinir o banco de dados do plugin. Faça uma cópia do código-fonte dos formulários HTML se precisar mantê-los.
  • versão 1.1.11:
    • Corrija uma pequena notificação PHP.
    • Possibilidade de usar a versão mais antiga do jquery UI (1.8) para a página do front-office (para resolver o conflito JS com algum tema e worpdress 3.5).
  • versão 1.1.10:
    • Novo recurso para integrar um formulário usando o código rígido PHP (diretamente nos arquivos de seu tema).
  • versão 1.1.9:
    • Corrigir erro de PHP 5.4 para $ _FILES.
    • Corrigir conflito com o plugin wp-recaptcha.
    • Corrigir o erro CSS para o botão UI definido no Chrome.
  • versão 1.1.8:
    • Corrigir erro AJAX para o site usando SSL.
  • versão 1.1.7:
    • Atualize o jquery UI para 1.9 para wordpress 3.5.
    • Novo CSS para minimizar o conflito com o tema wp CSS.
    • Se você atualizar o plugin de uma versão anterior para o 1.1.7 você precisa alterar a classe de seletor de classe HTML = "sombra" para class = "w2_shadow" para cada elemento de seus formulários.
  • versão 1.1.6:
    • Corrija o erro para a largura dos campos da caixa de seleção no Chrome.
    • Você pode adicionar seu próprio campo de arquivo personalizado no seu formulário.
  • versão 1.1.5:
    • Corrigir erro para configuração de configuração de campos quando o formulário tiver 0 campo obrigatório.
  • versão 1.1.4:
    • Corrigir "enviar a posição de alerta" para o erro inferior da versão 1.1.3.
  • versão 1.1.3:
    • Novo recurso para incluir vários formulários na mesma página.
  • versão 1.1.2:
    • Novo recurso para configurar automaticamente a seção de configurações de campos, verificando os elementos HTML do formulário com jquery.
  • versão 1.1.1:
    • Você pode enviar seu email via SMTP com autenticação (exemplo: gmail).
    • Novo método para criar seu próprio modelo HTML para a mensagem do corpo do correio.
  • versão 1.1.0 :
    • Você pode enviar seu e-mail via SMTP.
    • Corrigir o erro de codificação para utf_8 conteúdo na mensagem de correio para aceitar todo o tipo de personagem.
    • Corrigir mensagem de erro para o idioma de tradução em falta.
    • Corrigir o erro CSS para o IE9 e a entrada de arquivos personalizados.
    • Novo estilo CSS (redimensionamento automático) para uma melhor compatibilidade com WP Theme otimizado para iDevices.
    • Novo recurso de página de seleção para exibir o formulário em diferentes tipos de página (página, publicação, portfólio, produtos).
    • Possibilidade de especificar o rótulo para o valor do campo na mensagem de correio do corpo.
    • Função da página de seleção múltipla (para exibir o mesmo formulário em várias páginas).
    • Notificação de mensagem após a posição de envio (superior / inferior).


Comprar Agora !

Comentar